Page 1 of 1

"Modern" MAME not seeing keyboard

Posted: October 18th, 2017, 1:24 pm
by Ripcord
I'm having an odd problem that I haven't seen mentioned elsewhere, wondering if people have some ideas.

I'm finally upgrading one of my (Windows 7) emulation systems from ancient Mame (0.145) to more modern (trying 0.188, but anything relatively recent).

Even if I take a vanilla Mame install - freshly extracted, no config - it seems to refuse to see the keyboard on the system. If I load just the default menu (mame64.exe with no options), I can't navigate the menus, although typing letters will let me do searches.

Using the mouse I can navigate to menus, and if I look at control config lists, every item (like "P1 Up", "Pause", etc) just says "n/a", as if it doesn't think I have any control devices attached.

I can double-click on an item to try to map a key binding, which it lets me do, but then doesn't respond to any keypresses.

I've used my old config, wiped config (deleted all .cfg and .ini files and run mame64.exe -cc), used a "Fresh" install, all with the same result. I've even tried setting custom bindings in default.cfg for things like "UI_CONFIGURE" to "KEYCODE_TAB", but those settings still just show up as "n/a" in the UI.

I've tried flipping settings I see that seem like they might be relevant, like enabling/disabling multikeyboard, enabling/disabling joystick, etc. No change.

Mame 0.145 doesn't have this problem. 0.175 does (and 0.188). I haven't tested versions between .145 and .175 to see when the problem started, but I can.

Anyone have any suggestions?

Re: "Modern" MAME not seeing keyboard

Posted: October 21st, 2017, 9:11 pm
by Incito
Is this a wireless KB?

Re: "Modern" MAME not seeing keyboard

Posted: October 26th, 2017, 2:52 am
by Hierophant
Is Windows completely up to date?