MAMEUIFX64 - HISCORE not working for me

MAME Gurus come to your aide to help you. Please use the search before adding a topic. This will help cut down on having multiple topics with the same subject.
Post Reply
jimmybog
Member
Member
Posts: 6
Joined: June 4th, 2016, 7:33 am

MAMEUIFX64 - HISCORE not working for me

Post by jimmybog » June 6th, 2016, 5:50 am

Have installed MAMEUIFX-64bit 0.174 and have enabled the high score feature via the LUA plugins. My assigned folder for plugins is the /plugins folder in the MAMEUIFX64 root. I have the latest HIGHSCORE.DAT file in the MAMEUIFX46 root and another one in the /MAMEUIFX64/plugins folder

However, even though I play enabled games (for HIGHSCORE feature) no highscore is being saved for any game. I can’t see any generated *.hi files in the /hi, /score or /plugins/HISCORE folders

Also I’ve deleted any NVRAM files for the games in question

Can anyone help please?/

Thx

User avatar
PantherUK
Moderator
Moderator
Posts: 829
Joined: July 1st, 2012, 9:52 am
Favorite Game: Final Fight
Location: England UK

Re: MAMEUIFX64 - HISCORE not working for me

Post by PantherUK » June 6th, 2016, 6:14 pm

Double check to make sure all the required files and folders are not set to read only...
Ooer... No pictures...

User avatar
Hierophant
Site Administrator
Site Administrator
Posts: 3459
Joined: December 11th, 2008, 8:41 pm
Favorite Game: Alien vs Predator
Location: LV-426 Acheron
Contact:

Re: MAMEUIFX64 - HISCORE not working for me

Post by Hierophant » June 6th, 2016, 9:37 pm

G'day :hello:

I decided to do a live stream on our Twitch to investigate this problem:

https://www.twitch.tv/mameaddicts

I tried to figure it out on the fly. What I found is that you must go Options > Default Game Options > Miscellaneous II > Select a plugin drop menu > select hiscore > OK.

I tested this with Raiden and Space Invaders, which do not save high scores by default, but require the hiscore.dat. My high scores were saved after doing the above.

jimmybog
Member
Member
Posts: 6
Joined: June 4th, 2016, 7:33 am

Re: MAMEUIFX64 - HISCORE not working for me

Post by jimmybog » June 7th, 2016, 6:35 am

Hierophant wrote:G'day :hello:

I decided to do a live stream on our Twitch to investigate this problem:

https://www.twitch.tv/mameaddicts

I tried to figure it out on the fly. What I found is that you must go Options > Default Game Options > Miscellaneous II > Select a plugin drop menu > select hiscore > OK.

I tested this with Raiden and Space Invaders, which do not save high scores by default, but require the hiscore.dat. My high scores were saved after doing the above.
Thanks for the reply. That is exactly what I have done but it still didn't work. Can I ask, is there anything I need to do with pointing relevant folders to the correct location? I have pointed the "plugins" folder to my "plugins" folder in the MAMEUIFX-0.174 root. There is no option that I can see to point HISCORE to the HI folder as I have seen in previous tutorials

I will also double check that my files/folders are not set to READ only, though I'll be suprised if they are as I have not changed any READ/WRITE options since installing MAMEUIFX-0.174

jimmybog
Member
Member
Posts: 6
Joined: June 4th, 2016, 7:33 am

Re: MAMEUIFX64 - HISCORE not working for me

Post by jimmybog » June 7th, 2016, 2:33 pm

Just watched your live stream and followed the instructions exactly as you done them. And it still doesn't work. I extracted the latest hiscore.dat file into the MAMEUIFX-0.174-64bit root folder. Have also placed a copy of it in the /plugins/hiscore folder and also a copy in the /dats folder. I have tried to run the MAMEUIFX exe as ADMINISTRATOR but still no joy. Just completely refuses to save any high scores for me. I am running windows 10 with all the latest updates

jimmybog
Member
Member
Posts: 6
Joined: June 4th, 2016, 7:33 am

Re: MAMEUIFX64 - HISCORE not working for me

Post by jimmybog » June 8th, 2016, 4:22 am

I finally got it working!!!

What I done was to reinstall the MAMEUIFX-0.174-64bit package directly into a new folder on the C: drive as follows:

C:\MAMEUIFX-0.174-64


Previously I had it installed in a folder which is part of my User folder. E.g.

GEORGE\MAMEUIFX-0.174-64


So once I re-installed it direct to my C:\ drive and set the LUA plugin option, the Highscore feature now works correctly

All I can presume is that there was some kind of authority issue when installing/running from my User folder. Though not sure why this would be as my user id is set to administrator access level

But thanks for all your help and appreciate the time you took to create a webcast to discuss the issue

Regards

User avatar
Incito
Founder
Founder
Posts: 2097
Joined: June 5th, 2008, 3:20 pm
Favorite Game: Marvel vs. Capcom 2
Location: Metro City
Contact:

Re: MAMEUIFX64 - HISCORE not working for me

Post by Incito » June 8th, 2016, 1:19 pm

Cool, glad you got it sorted out. Hierophant actually dedicated the Monday live steam on this issue.
https://www.twitch.tv/mameaddicts/v/70997739

Skip pass 7 minutes as there was an audio issue and he had to start it from the beginning at that point.

Post Reply