Page 1 of 1

Cannot display in full screen on mame 0.152

Posted: May 10th, 2015, 7:57 am
by chowchunyi
I am new to mame and successfully installed version 0.152. However, the game screen does not cover the whole pc window. I tried a few options in the configuration but still failed.

If I could not solve it, I cannot have reasons to build my 1st arcade coffee table. Any help you may offer please? Thanks a lot. :sad:

Re: Cannot display in full screen on mame 0.152

Posted: May 10th, 2015, 7:14 pm
by Nostalgia
Try Alt+Enter.

Re: Cannot display in full screen on mame 0.152

Posted: May 10th, 2015, 9:03 pm
by Hierophant
When you say you tried the options, I assume you tried this:

Options > Default game options > Display > Run in a window not ticked > Start out maximized ticked.

Right?

Re: Cannot display in full screen on mame 0.152

Posted: May 11th, 2015, 11:56 am
by chowchunyi
1. ALT+Enter: crashed and end up with that directx error window message.

2. I updated both my NVIDIA GF video card driver and directx drivers. Not helpful.

3. Options > Default game options > Display > Run in a window MUST TICKED otherwise crash (point 1 above) > Start out maximized TICKED but no difference.

Kindly please help since I have tried all settings I understand. Thanks a lot. :lipssealed:

Re: Cannot display in full screen on mame 0.152

Posted: May 11th, 2015, 10:12 pm
by Hierophant
I did some searching and it might be an Nvidia bug in new drivers. More info here:

Constant reboot when starting MAME...FIXED! - http://forum.arcadecontrols.com/index.p ... c=111834.0

Re: Cannot display in full screen on mame 0.152

Posted: May 12th, 2015, 8:06 am
by Incito
I helped this member a little on YouTube. Here is what I had him try .... This way we don/t repeat.
Chun Yi Chow 3 days ago
I can only get mamePlus working in my win7 pc. The default screen looks ok as the games 1942 and many work in right ratio.

I want to make only the game screen appear in the middle, but not the background windows at the back. So how may I config it properly ?

Also, if I don't check the box of "Run in a Window", I would end up having a error message pops up saying some Direct3d issue.

Thank you for any help please.
Read more
Reply ·
Hide replies

Mame Addicts 2 days ago
+Chun Yi Chow Thanks for your post. Have you tried other video outputs? Go to default game options > Advanced.
Change the video output from Direct 3D to any other choice. Try all of them out and see if any of these will work. You could have an issue with Direct X as well. So in that same section you can try and change the versions under Direct 3D in the drop down menu. Mine shows versions 8 and 9. I am running 9 on my Windows 7 and 8.1.
This is the area where you will want to do a trial and error on all the settings until you get the result you want.
Reply · 1

Chun Yi Chow 2 days ago
+Mame Addicts I tried all 4 outputs, naming none, GDI, Directdraw and Direct 3D. However, if I press alt+enter trying to enlarge the window, it crashed with the same error message.

I have installed MS Direct X runtime but it does not help.

Besides, there is no "version" option that you mentioned on my screen under that section ?
Reply ·

Mame Addicts 2 days ago
What version of Mame are you running?
Also, you may need to re-install Direct X if running an older mame?
Reply · 1

Chun Yi Chow 2 days ago
Mame plus 0.152
Reply ·

Chun Yi Chow 1 day ago
+Mame Addicts 0.152. The games play ok, but only center in a rather small area. Certainly the full screen is expected but I can't get it working inside the config. I re-installed the Direct X already.
Reply ·

Re: Cannot display in full screen on mame 0.152

Posted: May 12th, 2015, 8:08 am
by Incito
Hierophant wrote:I did some searching and it might be an Nvidia bug in new drivers. More info here:

Constant reboot when starting MAME...FIXED! - http://forum.arcadecontrols.com/index.p ... c=111834.0
I (think) I told him to use DriverMax? Not sure that helps with the possible driver bug. Good find! :thumbsup: