Spy Hunter Sound Effects fix?

MAME Gurus come to your aide to help you. Please use the search before adding a topic. This will help cut down on having multiple topics with the same subject.
Post Reply
Spyhunter
New Member
New Member
Posts: 2
Joined: February 1st, 2014, 11:42 am

Spy Hunter Sound Effects fix?

Post by Spyhunter » February 2nd, 2014, 11:26 pm

Hi, I have been hoping for a long time now that the sound effects would be fixed in Spy Hunter for MAME. Is it a MAME issue or a ROM issue?

At this point it would seem that nobody knows that they are messed up, not all but ones like smoke, oil and the beloved chopper sound effects... I admit that it's hard to play on MAME anyway, but if you play with the settings enough, it is playable enough to have some fun with it! (I changed P1 Pedal 1 Inc to a button and wala the car cruises along as if it was in cruise control on high gear! You have to also reverse the pedal under analog controls)

This would not be too much of a shock as I had to identify to a member that built the first classic Midway arcade pack that featured the game on it for game systems and the PC that the music should not start from the beginning every time you enter a van! This really ruined the game as you can image!! Anybody remember that? The guy actually ended up recompiling the game for me, but it was still not perfect as the song would just pause after the death tune played, and when you went back into a van, it would just start from exactly where it left off, still a fail, but better than hearing it start from the beginning every time!

So yeah, help with the sound effects would be excellent, surprised that this was never fixed... Even though they spent awhile getting the rest of it to play I remember in the early days of Mame...

SH

User avatar
Hierophant
Site Administrator
Site Administrator
Posts: 3475
Joined: December 11th, 2008, 8:41 pm
Favorite Game: Alien vs Predator
Location: LV-426 Acheron
Contact:

Re: Spy Hunter Sound Effects fix?

Post by Hierophant » February 13th, 2014, 1:16 am

I tried for a while to see if I could compare the emulation to the original, but it's hard to find a vid on YouTube of a Spy Hunter machine with enough gameplay to check out the audio properly.

According to MAME, Spy Hunter is working with no problems flagged, so I do wonder if everything is OK at your end. I mean, it is a dual channel game so maybe you have a loose speaker wire in your MAME cab or something.

:unsure:

Spyhunter
New Member
New Member
Posts: 2
Joined: February 1st, 2014, 11:42 am

Re: Spy Hunter Sound Effects fix?

Post by Spyhunter » August 7th, 2015, 9:26 pm

You have it backwards, the arcade sounds much better than MAME, so if anything they had a wire loose when they were reading the ROMS to get the sounds for MAME. The MAME sounds are like a cheap home copy of the original, and I'm surprised there is still no movement on this.

SH

User avatar
Hierophant
Site Administrator
Site Administrator
Posts: 3475
Joined: December 11th, 2008, 8:41 pm
Favorite Game: Alien vs Predator
Location: LV-426 Acheron
Contact:

Re: Spy Hunter Sound Effects fix?

Post by Hierophant » August 9th, 2015, 6:37 pm

I see now that you successfully got this confirmed as a bug at MAME Testers - http://mametesters.org/view.php?id=5452. After listening to the direct comparison - http://mametesters.org/file_download.ph ... 1&type=bug - I can definitely agree with you that some Spy Hunter sound effects have not been emulated correctly.

Post Reply