Board index MAME Help Mouse not working in mame

Mouse not working in mame

MAME Gurus come to your aide to help you. Please use the search before adding a topic. This will help cut down on having multiple topics with the same subject.
Post January 25th, 2017, 1:17 pm
I am running mame on windows 7 pro 64 bit and 64 bit mame .172 from Launchbox/bigbox. I am using an ipac with a trackball. The trackball goes to the ipac and into the serial port. None of the trackball games are working, but the mouse works fine in windows. I changed mouse from 0 to 1 and trackball_device to mouse in mame.ini. Any idea how to get it working?

Post January 25th, 2017, 7:32 pm
Incito User avatar
Founder
Founder

Posts: 2013
Location: Metro City

1) Can you use the trackball to select stuff in Launchbox/bigbox?
2) Does your regular mouse work with trackball games?

I see you know your way around the mame filesystem (editing the .ini file).
Sometimes UI frontends dont play nice with the mame.ini. In GameEx (an older version mind you) you had another config to deal with.

Have you tried the games using only mame, as in launching it straight from the exe?

Post January 30th, 2017, 3:09 pm
I tried mame64 without any front end and the mouse did not work. I also tried a different usb mouse and it did not work.

Post February 2nd, 2017, 3:54 pm
Incito User avatar
Founder
Founder

Posts: 2013
Location: Metro City

Try another USB port.
What is the exact version of mame?
Also rename the mame.ini to say old.mame.ini, and then generate a new mame.ini.

Have you followed this video?



Return to MAME Help

Google+